Gutenprint and Gimp-Print for Mac OS X now vailable


Welcome to the Gutenprint Website [46.51 KB]

The Gutenprint project is pleased to announce Gutenprint 5.2.4-rc1, a release candidate from the stable branch of Gutenprint 5.2. This release offers several bug fixes from earlier Gutenprint 5.2 releases.

The release is an important one for users of Epson printers in particular, especially the following printers:
EPSON Artisan 700

  • EPSON Artisan 800
  • EPSON BX300F
  • EPSON EP-801A
  • EPSON EP-901A
  • EPSON EP-901F
  • EPSON ME 300
  • EPSON ME Office 360
  • EPSON PX-401A
  • EPSON Stylus NX100
  • EPSON Stylus NX105
  • EPSON Stylus Photo PX700FW
  • EPSON Stylus Photo PX800FW
  • EPSON Stylus Photo TX700W
  • EPSON Stylus Photo TX800W
  • EPSON Stylus S20
  • EPSON Stylus SX100
  • EPSON Stylus SX105
  • EPSON Stylus T20
  • EPSON Stylus TX100
  • EPSON Stylus TX101
  • EPSON Stylus TX102
  • EPSON Stylus TX103
  • EPSON Stylus TX105
  • EPSON Stylus TX106
  • EPSON Stylus TX109
  • EPSON TX300F

The latest release no longer supports OS X 10.2 however, so if you haven’t upgraded for a while perhaps now is the time to consider doing so.

Full details are listed in the release notes.

Advertisements

2 thoughts on “Gutenprint and Gimp-Print for Mac OS X now vailable

  1. Did you download and install Gimp-Print? It has better drivers even than Epson and should solve your problem. Let me know how you get on and if I can help in any way. If you use Snow Leopard the auto install for printers works well too.

    Steve :~)

  2. Hello,

    I had to put my G5 in the mac store to get it fixed and I plugged (USB) my Epson Artisan 800 into my other computer a desktop 15 inch imac and downloaded the drivers for the printer from epson.com. I downloaded the entire package (drivers and all the bells and whistles) for O/S X 10.4.4 (It looks as though my computer has 10.4.1 though) and i opened and installed the drivers and everything was good, so I thought. When I print for some reason, the printer just shoves the paper through slowly and prints nothing. (When it is printing, the status is something about “gimp printing epson 800), I don’t get this. Any ideas? Newer to mac. Thanks (as for the URL for my website, it will change soon to my own domain, just bookmark for now if you want to note it. Thx.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s